Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Fri, 12 Aug 2016 01:11:39 +0530 (IST)
From: P J P <ppandit@...hat.com>
To: oss security list <oss-security@...ts.openwall.com>
cc: Li Qiang <liqiang6-s@....cn>
Subject: CVE request Qemu: buffer overflow in vmxnet_tx_pkt_parse_headers()
 in vmxnet3 device emulation

   Hello,

Quick Emulator(Qemu) built with the VMWARE VMXNET3 NIC device support is 
vulnerable to an OOB read access. In that it does not check if packet headers 
does not check for IP header length. It could lead to a OOB access when 
reading further packet data.

Upstream patch:
----------------
   -> https://lists.gnu.org/archive/html/qemu-stable/2016-08/msg00077.html

This issue was reported by Li Qiang  if 360.cn Inc.

Thank you.
--
Prasad J Pandit / Red Hat Product Security Team
47AF CE69 3A90 54AA 9045 1053 DD13 3D32 FE5B 041F

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Powered by Openwall GNU/*/Linux - Powered by OpenVZ