Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Mon, 30 May 2016 23:13:15 +0530 (IST)
From: P J P <ppandit@...hat.com>
To: oss security list <oss-security@...ts.openwall.com>
Subject: CVE Request Qemu: block: iscsi: buffer overflow in iscsi_aio_ioctl

   Hello,

Quick Emulator(Qemu) built with the Block driver for iSCSI images(virtio-blk) 
support is vulnerable to a heap buffer overflow flaw. It could occur while 
processing iSCSI asynchronous I/O ioctl(2) calls.

A user inside guest could use this flaw to crash the Qemu process resulting in 
DoS OR potentially leverage it to execute arbitrary code with privileges of 
the Qemu process on the host.

Upstream patch:
---------------
   -> https://lists.gnu.org/archive/html/qemu-block/2016-05/msg00779.html

Reference:
----------
   -> https://bugzilla.redhat.com/show_bug.cgi?id=1340924

Thank you.
--
Prasad J Pandit / Red Hat Product Security Team
47AF CE69 3A90 54AA 9045 1053 DD13 3D32 FE5B 041F

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Powered by Openwall GNU/*/Linux - Powered by OpenVZ