Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Fri, 26 Jun 2015 02:10:40 -0700
From: Reed Loden <reed@...dloden.com>
To: rubysec-announce <rubysec-announce@...glegroups.com>, ruby-security-ann@...glegroups.com, 
	oss-security@...ts.openwall.com
Subject: rubygems <2.4.8 vulnerable to DNS request hijacking (CVE-2015-3900
 and CVE-2015-4020)

A bit old news, but I didn't see anybody post about this, so figured I'd
pass it on so folks know to update. Haven't seen updates by the distros
either.

MITRE's summary (updated):
"""
RubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.5, and 2.4.x before 2.4.8
does not validate the hostname when fetching gems or making API request,
which allows remote attackers to redirect requests to arbitrary domains via
a crafted DNS SRV record, aka a "DNS hijack attack."
"""

References:
*
https://www.trustwave.com/Resources/SpiderLabs-Blog/Attacking-Ruby-Gem-Security-with-CVE-2015-3900/
* http://blog.rubygems.org/2015/05/14/CVE-2015-3900.html
* http://blog.rubygems.org/2015/06/08/2.4.8-released.html
* http://blog.rubygems.org/2015/06/08/2.2.5-released.html
*
https://www.trustwave.com/Resources/Security-Advisories/Advisories/TWSL2015-007/?fid=6356
*
https://www.trustwave.com/Resources/Security-Advisories/Advisories/TWSL2015-009/?fid=6478

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Powered by Openwall GNU/*/Linux - Powered by OpenVZ