Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Mon, 19 Mar 2007 22:51:53 +0100
From: Till Maas <opensource@...l.name>
To: john-users@...ts.openwall.com
Subject: Re: Buffer Overflow warning with -fstack-protector and
 bigpatch 1.7.0.2 (des3-cbc-sha1)

On Mo März 19 2007, Solar Designer wrote:

> Till, Erik - care to try fixing that function to make it work with
> -fstack-protector?

I will help as much as I can, but I am not that much of an c expert.

> > Btw. why are the patches distributed apart from john?
>
> You've identified one of the reasons - the quality is often inadequate.
> Other reasons include dependencies on external libraries (in this case
> it's libdes or OpenSSL) and licensing issues.

What are the licensing issues? As far as I understand GPL, the patches have to 
be GPL, too. Or are there patent issues, too?

Regards,
Till

[ CONTENT OF TYPE application/pgp-signature SKIPPED ]

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ