Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Mon, 28 Aug 2006 10:54:52 +0200
From: Simon Marechal <simon@...quise.net>
To: john-users@...ts.openwall.com
Subject: Re: SSHA in JtR

Solar Designer wrote:
> On Tue, Aug 22, 2006 at 01:24:20PM -0600, jonemark wrote:
>> Not being an uber-programmer, I'm curious to know if anyone is  
>> considering building (or in the process of building) SSHA support for  
>> the 1.7.* version of John the Ripper.
> 
> Well, it seems not - although it would be trivial to update the existing
> patch for 1.7.x.
> 
> Simon - maybe you?..

Here is a patch with the two netscape ldap ciphers. The salted version
has never been tested (began writing it during a pentest, but found the
passwords another way before i finalized the plugin). It should work
when building with x86-generic, and might work with -mmx and -sse2.

** i strongly suggest you test it before using it for real **

http://btb.banquise.net/bin/john-1.7.2-netscape.patch.gz

-- 
To unsubscribe, e-mail john-users-unsubscribe@...ts.openwall.com and reply
to the automated confirmation request that will be sent to you.

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ