Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sat, 11 Apr 2015 13:01:22 +0200
From: Lukas Odzioba <lukas.odzioba@...il.com>
To: john-dev@...ts.openwall.com
Subject: Re: New SIMD generations, code layout

2015-04-01 10:13 GMT+02:00 magnum <john.magnum@...hmail.com>:
> An odd thing with MIC compared to AVX2 and below is the MIC doesn't have
> any "lower" support. Eg. you always know that an XOP capable system also
> supports (and defines) AVX, AVX also supports SSE4.1, SSE4.1 also
> supports SSSE3 and all of them supports SSE2. But MIC *only* supports
> the _mm512* intrinsics.

This is true only for current MIC generation - KNC, it will change in
the next one.

Lukas

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ