Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Fri, 23 Aug 2013 14:23:17 +0200
From: Dániel Bali <balijanosdaniel@...il.com>
To: john-dev@...ts.openwall.com
Subject: Re: Re: Daniel's weekly report #10

Hello!

I have not been able to patch any binaries since before yesterday.
We talked about this with Lukas yesterday, but the problem still exists.

I hope it's okay if I paste here what I sent to Lukas on IRC. This
describes what I'm doing and how it fails. The exact same process used to
work last week, now it does not. Here it is:

https://gist.github.com/balidani/a89c4949fd4309065f9b

Later we found out with Lukas that when I try to patch the same code that
was changed into NOPs into a binary it works. Also after changing a few
constants it still works. But when the ISA I try to patch has a different
structure (even if it's much shorter) it fails.

Does anybody have an idea what to do here?

Regards,
Daniel


2013/8/22 Lukas Odzioba <lukas.odzioba@...il.com>

> 2013/8/20 Dániel Bali <balijanosdaniel@...il.com>:
> > Priorities:
> >
> > 1. Get the 64-bit binary patching working
> > 1a. Get ds_add_u64 working (there is not much documentation on it)
> > 2. Continue trying to figure out the LDS problem
> > 3. Outline my priorities for the next weeks
>
> Could you sent here current status?
>
> Lukas
>

Content of type "text/html" skipped

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ