Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 23 Apr 2013 15:35:15 +0530
From: Dhiru Kholia <dhiru.kholia@...il.com>
To: john-dev@...ts.openwall.com
Subject: Re: Bleeding fails to build

On Tue, Apr 23, 2013 at 3:27 PM, Dhiru Kholia <dhiru.kholia@...il.com> wrote:
> On Tue, Apr 23, 2013 at 2:26 PM, Alexander Cherepanov <cherepan@...me.ru> wrote:
>> $ make -j4 linux-x86-64 > /dev/null
>> aix_ssha_fmt_plug.c:223: warning: implicit declaration of function
>> aix_ssha_fmt_plug.o: In function `crypt_all':
>> aix_ssha_fmt_plug.c:(.text+0x2bc): undefined reference to
>> `PKCS5_PBKDF2_HMAC'
>> collect2: ld returned 1 exit status
>> make[1]: *** [../run/john] Error 1
>> make: *** [linux-x86-64] Error 2
>
> This one is a known problem. I guess you are using an older version of OpenSSL.
>

commit a8418b1fc5a6a0a0642260a4b098e7f30536e9f1
Date:   Tue Apr 23 15:33:51 2013 +0530

    Fix build for older versions of OpenSSL


Does this commit fix the problem?

-- 
Dhiru

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ