Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 6 Mar 2013 22:59:43 +0100
From: magnum <john.magnum@...hmail.com>
To: john-dev@...ts.openwall.com
Subject: Re: Odf2John

On 6 Mar, 2013, at 22:36 , Rich Rumble <richrumble@...il.com> wrote:

> I'm encountering this error on win32 using Python 2.6 and 2.7.
> (py 2.6)
> 
> c:\john-1.7.9-jumbo-7\run\dist>c:\Python26\python.exe c:\john-1.7.9-jumbo-7\run\odf2john.py "c:\john-1.7.9-jumbo-7\Test File.odt"
> Traceback (most recent call last):
>   File "c:\john-1.7.9-jumbo-7\run\odf2john.py", line 110, in <module>
>     process_file(sys.argv[i])
>   File "c:\john-1.7.9-jumbo-7\run\odf2john.py", line 32, in process_file
>     elements = list(r.iter())
> AttributeError: _ElementInterface instance has no attribute 'iter'
> -------------
> 
> Using Cygwin's python for the same file (py 2.7.3)
> 
> $ python odf2john.py /cygdrive/c/john-1.7.9-jumbo-7/Test\ File.odt
> /cygdrive/c/john-1.7.9-jumbo-7/Test File.odt is not an encrypted OpenOffice file!
> 
> $ python odf2john.py /cygdrive/c/john-1.7.9-jumbo-7/Libre-Default_myhovercraftisfullofeels_.odt
> /cygdrive/c/john-1.7.9-jumbo-7/Libre-Default_myhovercraftisfullofeels_.odt uses un-supported checksum algorithm!
> 
> Test files are from http://openwall.info/wiki/_media/john/Office_Secrets.tar.gz
> -rich

Use odf2john.py with these files!

magnum

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ