Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Tue, 11 Sep 2012 08:11:22 +0200
From: magnum <john.magnum@...hmail.com>
To: john-dev@...ts.openwall.com
Subject: Re: Fix macosx-ppc32-altivec for gcc-4.3+

On 10 Sep, 2012, at 15:21 , Sam Novak <scitlands_army@...mail.com> wrote:

> https://github.com/magnumripper/magnum-jumbo/issues/82
> 
> I'm not sure if Apple just used different altivec extensions or what but you cannot compile jtr with powerpc when using a newer compiler.
> I've been working on a patch and managed to fix compiler errors for sboxes-s.c but compiler errors exist in DES_bs_b.c and I can't figure out where they are.
> 
> 
> <sboxes-s_gcc43+_powerpc.patch>


Solar,

Another short patch was later posted to https://github.com/magnumripper/magnum-jumbo/issues/82#issuecomment-8436582


Sam,

I gave Solar a heads-up and he responded in http://www.openwall.com/lists/john-dev/2012/09/08/6


magnum

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ