Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Sat, 21 Apr 2012 12:35:13 +0530
From: Dhiru Kholia <dhiru.kholia@...il.com>
To: john-dev@...ts.openwall.com
Subject: JtR compilation warnings on OS X 10.7.3 with Xcode 4.3.2

Hi,

I tried compiling magnum-jumbo on OS X 10.7.3 with Xcode 4.3.2 (with
Command Line Tools for Xcode installed) and got tons of warnings
(compilation log attached).  Almost all of them were regarding some or
the other OpenSSL calls being deprecated. Are these warnings easy to
fix?

$ openssl version
OpenSSL 0.9.8r 8 Feb 2011
$ gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc.
build 5658) (LLVM build 2336.9.00)

-- 
Cheers,
Dhiru

View attachment "Lion-Compilation-Log.txt" of type "text/plain" (50293 bytes)

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ