Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sat, 17 Mar 2012 12:51:07 +0530
From: Dhiru Kholia <dhiru.kholia@...il.com>
To: john-dev@...ts.openwall.com
Subject: Re: VNC Pcap's for cracking

On Wed, Mar 14, 2012 at 10:02 PM, Dhiru Kholia <dhiru.kholia@...il.com> wrote:
> I have integrated VNCcrack into JtR. See
> https://github.com/magnumripper/magnum-jumbo. For testing, I used
> TightVNC server 1.3.9 (on Ubuntu 11.04) & TightVNC client 1.3.10 (on
> Windows 7) which use RFB Protocol Version 3.8. Testing and adding
> support for other VNC servers and protocol versions is TODO. For now,
> vncpcap2john.cpp (included in git repository) needs to be compiled
> separately.

Update:

According to RFB documents, vnc_format_plug.c can be used to crack all
versions of RFB protocols (3.3, 3.7 and 3.8). They all use same VNC
authentication scheme. I have tested it against 3.7 and 3.8 versions.
However vncpcap2john.cpp is currently limited to cracking TightVNC
generated pcap files. I am working on extending vncpcap2john to
support other servers.

-- 
Cheers,
Dhiru

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ