Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sun, 18 Sep 2011 02:22:52 -0400
From: David Jones <jonesd@...umbus.rr.com>
To: john-dev@...ts.openwall.com
Cc: David Jones <jonesd@...umbus.rr.com>
Subject: Re: Patch for dynamically loaded formats


I added 2 items to the wiki contributions page: a newer version of the patch to add the 'plugin' option;  and an 'OpenVMS support' kit in the closely related files table.  I started up my old SuSe linux box and fixed a problem with the dlopen() call.

The kit is a zip file that contains, in addition to the openvms format extension to John the Ripper, a program (uaf_to_passwd.c) to convert OpenVMS authorization data to a passwd file for John to munch, as well as support code that allows the john executable to be built on OpenVMS 8.3.  The kit is compatible with both the stock 1.7.8 release and the jumbo 6 release candidate (a patch file to add dynamic library plugin support to 1.7.8 is included).

>>Dave

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ