Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sat, 2 Jul 2011 15:51:19 -0500
From: "JimF" <jfoug@....net>
To: <john-dev@...ts.openwall.com>
Subject: Re: 1.7.8.Jumbo-1


----- Original Message ----- 
From: "Solar Designer" <solar@...nwall.com>
>
> Then the patch should be reworked to use the same approach that
> john-1.7.7-jumbo-6-auto_have_sha256-03.diff.gz does.  Would you do that?

I had problems with that patch. I was able to build, but link failed, on one 
sparc box, and build and link worked on another, but the shared libs did not 
have proper exports on another sparc box.  Now, it is VERY likely, that 
these boxes were not setup properly.  However, I have no reason to ask for 
oSSL to be updated properly, thus can not make that type of request on these 
systems.  Thus, this keeps john from being usable there.

> I am tempted not to apply john-1.7.7-jumbo-6-jimfpatch-4.diff for now,
> because it does not apply on top of john-1.7.7-jumbo-6-zip-0.diff.gz
> anyway (most hunks are rejected) and because fixing it to make it apply
> feels like a waste of time (I think it needs to be re-done to check the
> OpenSSL version number).
>
> I might include the DOMINOSEC_fmt.c, lotus5_fmt.c, and sapB_fmt.c hunks
> now, though.
>
> Thanks,
>
> Alexander 

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ